实用云,提供最全最实时的云市场资讯

手机站:/m

游戏服务器_我是证人百度云_怎么申请

时间:2021-09-08 11:06编辑:实用云来源:实用云当前位置:主页 > 云存储服务 >

为了与业界在安全性和数据完整性方面的最佳实践保持一致,SAP SuccessFactors计划停止对TLS 1.0的支持。如果您在SAP云平台上安装了SAP SuccessFactors extensions,请检查下面您的应用程序是否会受到此更改的影响,并确保您提前采取建议的操作以避免服务中断。

哪些应用程序不受影响?

未对SAP SuccessFactors进行任何API调用的应用程序。包括SSO在内的前端集成也不会受到影响HTML5应用程序。这些应用程序将自动适应这种变化,并将使用更高的TLS协议版本在JRE 8上运行的Java应用程序,使用HTTP目标API或ConnectionConfiguration API,哪个云服务器,在建立与SAP SuccessFactors API的连接时未明确指定TLSv1

哪些应用程序受到影响?

更改可能只影响Java应用程序。HTML5应用程序将不受影响,并将自动采用此更改,并将切换到TLS协议的更高版本。

您的应用程序是否受影响以及建议的操作取决于您如何建立与SAP SuccessFactors的连接以及您用于运行应用程序的JRE版本:

Java在JRE 6或JRE 7上运行的应用程序,并使用HTTP目的地API创建HttpClient,以便调用SAP SuccessFactors API。

常见的指示是这样的源代码:

在这种情况下,您的应用程序必须在7月27日之后重新启动,以采用支持TLS 1.1和TLS 1.2的最新SAP云平台运行时版本

Java应用程序在其上运行JRE 6或JRE 7,使用ConnectionConfiguration API,移动物联网,在建立与SAP SuccessFactors API的连接时,不要明确指定任何TLS版本。

通常的指示是这样的源代码:

在这种情况下,您的应用程序必须在7月27日之后重新启动,以采用支持TLS 1.1和TLS 1.2的最新SAP云平台运行时版本

Java应用程序在建立与SAP SuccessFactors API的连接时,请使用ConnectivityConfiguration API并显式指定TLSv1

通常的指示是这样的源代码:

在这种情况下,您需要将应用程序更改为使用更高的协议版本或根本不使用任何特定版本(SSLContext.getDefault文件())然后重新部署并在7月27日后重新启动。

使用任何其他库和API建立与SAP SuccessFactors API连接的Java应用程序。

在这种情况下,大数据课程,您需要确保这些库支持TLS 1.1和TLS 1.2,并且在源代码中不显式使用较低的协议版本。有关第三方支持的更多信息,请参阅SAP SuccessFactors公告。

固定SAP云平台运行时

在上述任何情况下,如果您的应用程序运行在JRE 6或JRE 7上,并且固定到特定的SAP云平台运行时版本,云服务器租用,您应该执行以下操作之一:

取消固定以在7月27日之后使用支持TLS 1.1和TLS 1.2的最新SAP云平台运行时版本。重新部署应用程序,添加以下VM参数。查看SAP Cloud Platform文档以了解如何配置VM参数

检查JRE版本

要检查应用程序正在使用的JRE,可以使用显示应用程序属性SAP Cloud Platform SDK for Neo environment命令或导航到应用程序JMX控制台,java.lang.Runtime运行时在SAP云平台中驾驶舱(见下面的屏幕截图)

,淘客推广怎么做

上一篇谷歌云_数据库招聘_优惠券

下一篇域名注册_大华视频服务器_企业级

世界之最排行

世界之最精选